Screenshots

From EG1003 Lab Manual
Jump to: navigation, search

How to Capture PC Screen Images

It's been said that a picture is worth a thousand words, and showing the contents of a PC screen as part of a Word document or a PowerPoint presentation can greatly add to the clarity of the material being presented.

Fortunately, it is very easy to do this. This document will walk you through the process, and make it easy for you to include "screen shots" in the material you produce.

For most software, we'll describe how to capture the screen image and then manipulate it. For Microsoft Project, the process is slightly different, and is described after we've discussed other software.

Capturing the Image Other Than Microsoft Project

When you want to keep a copy of what's on the screen, just press the "Print Screen" key.  The "Print Screen" key is at the very top of the keyboard on the right side, and usually has a caption of "Print Screen/SysRq". When you press this key, you will capture what ever is showing on the screen (an exact image) on to the Windows "Clipboard" for use later, as if you did the "Copy" operation as part of a "cut and paste" procedure.

Capturing the Image with Microsoft Project

If you want to capture the screen shown in Microsoft Project (e.g. the Gantt Chart or Resource List), click on the "Copy Picture" icon on the right side of the Project menu. The icon looks like a camera, and is usually located next to the "Help" (question mark in a yellow box) icon. This will bring up a "Copy Picture" dialog box. Under the "Render Image" menu, click the "To GIF image file" button and fill in a file name you can remember in the box. Also, note the directory name where the file is being stored so you can find it again. Finally, click "OK" to save the file.

This usually gives you a better picture than the method described above. Once you're captured the image, you can continue with the steps below.

Editing the Image

Now that you've captured the screen image, it will probably be necessary to clean it up. For example, the Windows taskbar is probably present at the bottom of the screen, and you'd like to remove it from the image before using the image. Frequently, the menus and scrollbars present on the screen are also not of interest, and you'd like to remove them.

The easiest way to accomplish this is to use the "Paint" program included in Windows. To bring up the Paint program, click on "Start" to bring up the menu, and then "All Programs" to display all the programs, then "Accessories" and "Paint". This will start the Paint program with a blank white default canvas.

On the menu at the top of the screen, click on "Edit" and you'll get a drop down menu. The "Paste" item should be selectable, so click it. Your screen image should then appear on the canvas. If the Paste item could not be selected, or what appeared was not your screen image, then go back to the preceding section and try to capture the image again and paste again, until the image appears.

Note: At this point the screen can be a little confusing since you have the Paint menus and scroll bars, plus the menus and scroll bars from the image you captured. Keep this in mind as you work. Most importantly, keep in mind that since you captured an entire screen, and the canvas shown is only part of the screen, that the scroll bar at the right and at the bottom are the Paint program's, and not part of your screen shot.

First of all, you'll probably want to be able to see the entire screen image, and not just part of it. To do this, we'll shrink the image a little. On the Paint menu, Click on "Image" and "Stretch/Skew". In order to avoid distorting the image, do not do anything with the two "Skew" numbers, and be sure to keep the two "Stretch" numbers the same. For the "Skew" numbers, they are currently both 100%. Using smaller numbers will shrink the image, and larger numbers will enlarge it. Since we want to shrink the image a little, we'll enter numbers slightly less than 100. Try entering 85 in the two "Stretch" boxes and click OK. At this point the entire screen shot should be visible on the canvas. If it isn't, you can restore the image by going up the Paint menu and clicking "Edit" and "Undo" to restore the image back to 100%. You can then repeat the shrinking process using different numbers until you get the results you want.

At this point it's a good idea to save your work. That way, if you mess things up later, you can just reopen the image and start working again. On the Paint menu, click "File" and "Save As", and use a name of your choice for the filename. Just be sure to remember it later, and also note the directory where you're saving the image. After you've entered the name, click OK, and you'll have the image available for recovery if necessary.

Now that you can see the entire image, we'll just keep what we want. On the left side of the window there's a set of Paint tools. The one that's highlighted is the "Select" tool. What this tool does is allow you draw a box of what you want to keep. On the canvas containing your screen image, place your mouse at the top left corner of the material you want to keep. Notice that when your mouse is on the canvas, that the cursor turns into a crosshair to make it easy to choose what you want precisely. Then press the mouse button and "drag" the mouse down to the bottom right corner of the material you want to keep. Paint will show an outline of the box containing the material. When the bottom right corner is in the right place, release the mouse button and the dotted box will remain, showing you what you've selected. If the box isn't right, try this process again until the box has what you want.

We'll now keep what we want and throw away the rest. On the Paint menu, click "Edit" and "Cut". This will cause a big hole to appear in the image, where what you want will now be missing. If you selected the wrong material, the hole will make this clear. In that case, go up to the Paint menu and click "Edit" and "Undo" to put things back. Then make another box as we described above and try again.

Once you've cut the proper material, we'll now work on it alone. Click on "File" and "New" to get a new canvas. If Paint asks you if you save the old image, click "No".

Note: If you click "Yes", it will save the image with the hole on top of your good image. Don't do this!

When you get the new canvas, click "Edit" and "Paste" and you'll get back just what you selected when you did the cut operation earlier. If you want, you can now do this operation again to get a part of this image. Usually after one or two times around, you'll have just what you need. At this point we're ready to use our image.

If you want, you can just move the image from Paint to the document where you want to use the image, but it's usually a better idea to save this work and then insert it later. That way in case you need the image again, it'll be readily available to you. Therefore, that's the method we'll use.

First, we'll save our work. On the Paint menu, click "File" and "Save As" again, but this time we're going to be more careful. You'll see an item "Save As Type". Click on the arrow at the right, and you'll get e "drop down" menu containing a large number of file types. At this point we'll briefly describe what each type is, and what it's good for:

Monochrome Bitmap (.bmp): This will be a black and white image. Since it doesn't contain color, it's usually not what you want. However, if your image only has black and white information, then this format might be appropriate. One issue to keep in mind is that bitmap images (all of which have the bmp file extension), have numeric values for each point on the screen, and tend to be large. Some of the other formats will compress the image with (usually) negligible loss of quality. Therefore, if the highest possible quality is required, use a bitmap format. However, for almost any general purpose work, use one of the compressing formats. If you must use a bitmap format, monochrome will be the smallest, but it will have no color information.

16 Color Bitmap (.bmp): This is the first of the three color bitmap formats. All three have a tradeoff of color quality versus file size. 16 bit color will have the smallest size of the bitmap formats, but image quality is extremely poor. You probably won't want to use this format.

256 Color Bitmap (.bmp): This format can be used for some screen shots that don't have much color. However this format will probably not be good for things like pictures and other images where there are lots of colors and tones. Once again, no compression is done, so these files tend to be large. 256 Color Bitmaps have largely been replaced by the GIF which offers the same color depth but a smaller file size.

24 Bit Color Bitmap (.bmp): This format has the best color quality of the three color bitmaps, but the files sizes tend to be very large since there is no file compression. This is probably the format you want to use if you need the highest image quality, at the expense of file size.

JPEG (.jpg): This is a color format that does a high compression of the image, with a small (frequently undetectable) loss of quality, but with MUCH smaller file sizes. JPEG stands for Joint Photographic Experts Group, the name of the industry group that defined the standard. This format is widely used on the Internet and many other places.  This format is the best for photographs and images that have a lot of colors.  However due to the lossy compression it is not ideal for diagrams with sharp edges or lines, such as circuit diagrams.

GIF (.gif): This is a color format that compresses the image without any loss of quality.  However it only supports up to 256 colors so like the 256 Color Bitmap it is only useful for images that don't have many colors.  Historically, it is the oldest compression format, and is called the Graphical Interchange Format. It is still widely used, but JPEG is typically used more often.  This format is often the best for diagrams with a lot of edges but few colors like sketches, circuit diagrams, text, etc.

TIFF (.tif): This is a color format called the Tagged Image File Format. Like GIF, it is one of the oldest formats, and has largely been supplanted by JPEG and others.

PNG (.png): This is a color format called the Portable Network Graphics format, and is one of the newest. It is rapidly growing in popularity, especially on the Internet. PNG supports up to 24 Bit color and compresses the image without any loss of quality. The file size will be larger than a JPEG but smaller than a Bitmap. PNG is a good all-purpose format so if you are unsure of what to use, use PNG.

With so many formats, which one should you use? For most work, JPEG, PNG or GIF (for low color images) are probably the most desirable. For use on Web pages, PNG is particularly effective, but JPEG is more widely used within programs. Some programs require a specific file format, so Paint supports a number of formats to be able to exchange data with them. However, for EG1003 your primary tools are Word and PowerPoint, which support JPEG, PNG and GIF, so you should probably stay with just those formats.

After you've selected the format you want to use, enter a filename, and note the directory where the file is being stored so we can find it later.

Now that you've saved your image, it's time to include it in your work.

Putting the Image in Your Work: Office 2003 Word

Place your cursor where you want to insert your image. On the Word menu select "Insert" and "Picture". From the drop down menu that appears, select "From File". This will then do a directory list of files. The starting directory is usually (but not always) "My Pictures", which is the place where Paint usually stores its images. Therefore, you should see the image you stored in Paint in the file list, so just select it. If you're in the wrong directory, you'll have to navigate to the proper place and then select the file.

The image will now appear in your Word document. Note that when the image is inserted, the surrounding text will probably be moved, possibly in ways you don't like. This is not a big problem, if you right click the image and select "Properties" you'll see that you can change how the image behaves, and do things like "wrap" the text around the image. Most of the time, however, things will be the way you want them in the first place.

You can also change the size and shape of the image if you want. If you left click on the image, a frame will form around it with a small square in each corner and the middle of each side. If you click on one of the squares and drag the mouse, it will resize the image in various ways. If you click on one of the squares on the sides of the image, it will stretch and shrink the image in the horizontal direction. Similarly, if you click on one of the squares on the top or bottom, it will stretch and shrink the image vertically. If you click on one of the corner squares, it will resize the image, but keep it undistorted. Therefore, it is probably desirable to use the corner squares when changing the size of the image.

Putting the Image in Your Work: Office 2007 Word

Place your cursor where you want to insert your image. On the ribbon, click on the Insert tab. Click on the Picture icon in the Illustrations group. On the popup window that appears, navigate to the directory where your picture is and double click on the picture.

The image will now appear in your Word document. Note that when the image is inserted, the surrounding text will probably be moved, possibly in ways you don't like. This is not a big problem, if you right click the image and select "Properties" you'll see that you can change how the image behaves, and do things like "wrap" the text around the image. Most of the time, however, things will be the way you want them in the first place.

You can also change the size and shape of the image if you want. If you left click on the image, a frame will form around it with a small circle in each corner and a small square in the middle of each side. If you click on one of these, and drag the mouse, it will resize the image in various ways. If you click on one of the squares on the sides of the image, it will stretch and shrink the image in the horizontal direction. Similarly, if you click on one of the squares on the top or bottom, it will stretch and shrink the image vertically. If you click on one of the corner circles, it will resize the image, but keep it undistorted. Therefore, it is probably desirable to use the corner circles when changing the size of the image.

Putting the Image in Your Word: Office 2003 PowerPoint

Move through the presentation to the slide where you want to include your image. On the PowerPoint main menu select "Insert" and "Picture". From the drop down menu that appears, select "From File". This will then do a directory list of files. The starting directory is usually (but not always) "My Pictures", which is the place where Paint usually stores its images. Therefore, you should see the image you stored in Paint in the file list, so just select it. If you're in the wrong directory, you'll have to navigate to the proper place and then select the file. The image will now appear on the slide.

You can also change the size and shape of the image if you want. If you left click on the image, a frame will form around it with a small square in each corner and the middle of each size. If you click on one of the squares and drag the mouse, it will resize the image in various ways. If you click on one of the squares on the sides of the image, it will stretch and shrink the image in the horizontal direction. Similarly, if you click on one of the squares on the top or bottom, it will stretch and shrink the image vertically. If you click on one of the corner squares, it will resize the image, but keep it undistorted. Therefore, it is probably desirable to use the corner squares when changing the size of the image.

Next, you can put your cursor in the middle of the image and "drag" it around on the slide to the desired location. Usually a combination of dragging and resizing the image will give you exactly the effect you want.

Putting the Image in Your Word: Office 2007 PowerPoint

Move through the presentation to the slide where you want to include your image. On the ribbon, click on the Insert tab. Click on the Picture icon in the Illustrations group. On the popup window that appears, navigate to the directory where your picture is and double click on the picture.

You can also change the size and shape of the image if you want. If you left click on the image, a frame will form around it with a small circle in each corner and a small square in the middle of each side. If you click on one of these, and drag the mouse, it will resize the image in various ways. If you click on one of the squares on the sides of the image, it will stretch and shrink the image in the horizontal direction. Similarly, if you click on one of the squares on the top or bottom, it will stretch and shrink the image vertically. If you click on one of the corner circles, it will resize the image, but keep it undistorted. Therefore, it is probably desirable to use the corner circles when changing the size of the image.

Next, you can put your cursor in the middle of the image and "drag" it around on the slide to the desired location. Usually a combination of dragging and resizing the image will give you exactly the effect you want.

 

Return to Table of Contents