Microsoft Project Skill Builder

From EG1003 Lab Manual
(Redirected from MS Project Skill Builder)
Jump to: navigation, search

Objectives

To create a Microsoft (MS) Project schedule for your semester-long design project by performing the instructions that follow and using Figure 1 as a sample.

Figure 1: A Typical Project Plan

Note that tasks are ordered chronologically and an estimate of the amount of time it takes to perform each task is specified.

Your Assignment

Your TA will show you how to use MS Project to create the elements you will need to complete this assignment. MS Project 2010 has introduced several new features to the application. This exercise will familiarize you with MS Project's features, whether you have used previous versions or not. This assignment will not be graded or submitted, but finishing this exercise should equip you with the necessary skills needed to successfully plan for your semester-long design project and to prepare a project schedule representation.

Procedure

Start a New Project Plan

  1. Launch MS Project. Open the Start Menu. Expand the All Programs group, then the Microsoft Office group. Click on Microsoft Project 2010. The screen shown in Figure 2 appears.
    Alternatively, you can type "project" into the search field of the Start Menu and click on Microsoft Project 2010.
    Figure 2: Project Startup Screen (partial image)

    One of the more notable new features of MS Project 2010 is the Ribbon, the main navigation bar that allows easy access to commonly used tools. The Ribbon contains several tabs that feature tools and commands grouped by their function. Under the Ribbon the window is divided into two sides: the task list on the left and the time view of the project on the right. The default time view is known as the Gantt Chart.
  2. Customize your project plan. Project opens with a blank project, so all we need to do is customize it. Select the Project tab on the Ribbon, then select Project Information. In the dialog box that appears, click on the arrow next to the box labeled Schedule From. From the dropdown menu that appears, select Project Finish Date. Note that the Finish Date box above is no longer gray, and you can enter a date into it (and the Project Start box is now gray instead). You can only schedule a project from one place, and you've now selected the end date when your project is due. Enter the date you expect to finish here or click the dropdown arrow to open a virtual calendar to select the due date. Click OK.
    Note: Make sure that the current date is correct and that the calendar is set to Standard.
    Note: If you want, you can use the start date for your project, but make sure that the overall schedule completes by the due date.
  3. Click on the View tab on the Ribbon, and then select Gantt Chart if it's not selected already. The Gantt Chart is the most widely used form of schedule in the industry, and shows time flowing from left to right. Other views might be used in some circumstances, but we don't need them for EG1003.
    Let's stop and examine the screen more carefully. The blank Gantt chart fills most of the screen, and consists of two parts. The left side is the list of tasks in the schedule, and consists of a number of columns. The right side is a calendar that goes from left to right. We'll work on each side of the screen separately, but MS Project will make sure they are consistent with each other.
    We'll now review the list of tasks. The list looks similar to an Excel spreadsheet, so it will be easy to learn how to use it — the interface is the same. The row numbers are blank in the gray column on the left side. This is because you haven't created any tasks yet. As you do, the numbers will fill in automatically. This column of numbers is called the Task ID. The next column has a letter "i" inside a blue circle. This is the Indicators column. Most of the time it will be blank when a task is not completed yet, and will contain a check mark when it is. The next column, called Task Mode, is used to either allow you to schedule the task manually or let MS Project automatically schedule the task's Duration, Start time, and Finish time for you based on certain factors such as dependencies, constraints, calendars, etc. The next column is the Task Name, which you enter. You can choose any text you want for a task name, but it should be clear to anybody looking at the schedule what the task is. The next three columns are the Duration, Start time, and Finish time of the task. When you first enter a task, these three columns are left blank. You can estimate two of three pieces of information and enter them into their respective columns. We'll discuss this more later.
    Tasks in a project frequently interact. Typically, one task determines how the other task is scheduled. The task that sets the schedule is called the predecessor task, and the one that has its schedule set by the predecessor task is called the successor task.
    The next column is Predecessors, which are the tasks you identify that control how this task is scheduled. The last column is Resource Names, which we'll discuss later.
    Depending on your screen resolution, some columns on the task list side will be hidden from view. To show this hidden information, move the mouse cursor to the thick bar between the two sides and drag it to the right until the desired number of columns is shown.
  4. Insert your tasks. To do this, move your cursor to the first box below Task Name and click on the box so we can enter text there. Type in a descriptive name for the task. Repeat this process for all the tasks needed for your project. You might not know all the tasks required, but enter as many as you can. We can always add more tasks or delete unnecessary ones later.
  5. When these tasks interact, there are four ways they can interact. The second task must start when the first one ends (called Finish-to-Start in Project), the second task must end when the first one starts (called Start-to-Finish), the second task must start when the first task starts (called Start-to-Start), or the second task must end at the same time as the first one (called Finish-to-Finish). These interactions are called dependencies. Microsoft Project 2010 uses the Finish-to-Start dependency by default. To designate one of the other dependencies, type SF, SS, or FF next to the task number in the predecessors box, as described below. For EG1003, we will use the Finish-to-Start relationship.
    Frequently, you have a list of tasks, where each successor's start should be the predecessor's finish. Project has a way to do this quickly. Select the first task, hold down CTRL and select the next task. Repeat this process until all the tasks you want to connect are highlighted. Click Link tasks, the button with the chain icon on it, located on the Task tab of the Ribbon to arrange the selected tasks properly. Notice that on the Gantt Chart, a connecting arrow from the finish of each predecessor task is connected to the start of each successor task, showing their relationship graphically. As an alternative, you can set the predecessors for each task manually. Start by dragging the bar between the task list and the calendar so that you can see the Predecessors column. Put the Task ID of the predecessor tasks in the cell. If you don't show the dependency type, Project will choose Finish-to-Start by default. If you want a different choice, use the proper two letter abbreviation. The following are some examples of how to show predecessors. For each one, what you'd type is shown in italics, and its meaning follows:
    • 1 This makes task 1 the predecessor for this task. Finish-to-Start is chosen by default.
    • 1FS This is the same as the preceding item, except we showed the relationship to help clarity. #* 1SS This says that this task must start at the same time as task 1
    • 1FF This says this task must end at the same time as task 1
    • 2SF This says that this task must end when ask 2 starts.
    • 1FS, 2FS This says that this task should start when both task 1 and task 2 are finished. Whichever of these tasks finishes last determines the start of this task. Project will figure this out automatically.
    Note: You can change the relationship of the linked tasks later. Either you can reenter or edit the information in the task list cell by clicking on it and changing it the same way you would in Excel. You can also double click on the connecting arrow from the right side of the predecessor task to the top of the successor task on the Gantt Chart. A window will appear showing the task dependency. You can click on the arrow next to the existing type and choose a different type, with the same meanings described earlier.
    You can also choose the amount of lag time between tasks. Sometimes you need to introduce lag time. For example, after concrete has been poured, tasks that depend on the concrete need to be delayed until the concrete has hardened. You can account for this with a "Concrete hardens" task of the proper duration, but that clutters the schedule. Instead, we can introduce a delay between the end of the predecessor task and the successor task, called lag time. If you're entering information into the task list cell, just add the lag time you want by putting a plus sign and the lag time. If you're using the Task Dependency window, you can enter the lag time on the right side of the window. Project chooses a default of no lag time to allow the project to be done in the minimum time, but now you can override it if you want. The following are some examples of how to show predecessors with lag time. For each one, what you'd type is shown in italics, and its meaning follows:
    • 1+1d This makes task 1 the predecessor with Finish-to-Start by default, and one day of lag time.
    • 1FS+1d This is the same as the preceding item, except we showed the relationship to help clarity.
    • 1SS+1w This says that this task must start one week later than the start of task 1
    • 1FF This says this task must end at the same time as task 1
    • 1FS+3d, 2FS+1d This says that this task should start when both task 1 has been finished for 3 days and task 2 has been finished for one day. Whichever condition is later determines the start of this task. Project will figure this out automatically.

Changing the Timescale

Note: The Microsoft Project 2010 default setting for the Gantt Chart is a daily schedule. You will need to change this timescale for your independent project in order to show all data.

  1. Click the View tab of the Ribbon. Timescale is located inside the Zoom area of the Ribbon. Click the dropdown list arrow where the default setting is days; this list contains several commonly used time periods that format the bottom tier of the calendar and range from hours to years. Although these time periods format the bottom tier, the top tier may be affected as well depending on which time period is selected. At the bottom of this list, select Timescale. As an alternative, right click on the dates at the top of the Gantt Chart's calendar, and on the pull down menu that appears, select Timescale.
  2. In the window that appears, under Middle Tier Formatting, click on the arrow next to the Units field and choose Months.
  3. Click on the Bottom Tier tab at the top of the window. Click on the arrow next to the Units field and choose Weeks from the pull down menu.
  4. Click OK.

Setting Task Duration

In the Duration column highlight the cell for the task you would like to adjust and enter the desired duration. To designate a duration, use:

  • m for minute
  • h for hour
  • d for day (this is working days, not calendar days - weekends are skipped)
  • w for week
  • mon for month
  • ed for elapsed days

Microsoft Project 2010 automatically converts these designations to their normal abbreviations.

Naming Resources

A project may need many different types of resources. For your project, and for most other activities, one obvious set of resources is the people involved on the project. Special equipment would be another resource. For example, if you needed a backhoe for a week and had to rent it, the use of the backhoe should be included in your schedule so you don't forget to order it, and also to include its cost. We'll now consider how to include resources on your schedule:

On the Ribbon, click the View tab. In the Resource Views area of the ribbon, click Resource Sheet. Your schedule will be replaced by another spreadsheet where you can show resources. For your EG1003 project, you need to enter the names of the people on your project team as the resource names. However, since your project also requires a cost estimate, we can add other items. For example, one part of your estimated cost is the labor of your team. The rate to use is shown elsewhere in this manual, but you can enter this rate for each person in the Std. Rate column. We'll ignore the other columns, but professionals usually make heavy use of this information and fill in everything. When you're done, you can return to your schedule by selecting Gantt Chart to the far left of the ribbon in the same tab. This will return you to the view you had earlier.

Manual/Automatic Scheduling

Previous versions of MS Project automatically altered task dates to fit the changes that were made to imperative project elements such as task dependencies, the project calendar, and others. One of the new features of Microsoft Project 2010 is the option of scheduling your tasks either manually or automatically. Manual Scheduling disables Project from touching your task dates; thus leaving all scheduling up to you. You can also distribute manual/automatic scheduling among your tasks—you don’t need to have all tasks manual or automatic. If tasks get too complicated to manage on your own, turn on automatic scheduling to allow MS Project to adjust tasks dates. Since manual scheduling is the default setting, turn on automatic scheduling by:

  1. Select one or more tasks to be modified. On the Tasks group of the Ribbon’s Task tab, click the Auto Schedule button
  2. Click the Task Mode cell of the desired task; then click on the dropdown arrow to select either Manually Scheduled or Auto Scheduled.
  3. To set the default scheduling of all new tasks, click on the New Tasks: Manually Scheduled button on the status bar (at the bottom of the MS Project screen). Select Auto Scheduled on the list that appears.
  4. Right-click any cell or the graphic representation on the Gantt Chart of the desired task; then select Auto Scheduled on the list that appears.

These same steps also apply for turning on manual scheduling. Notice the push-pin icon for manual scheduling, and the box with right arrow icon for auto scheduling.

Assigning Resources

In MS Project 2010, assigning resources to tasks has been simplified thanks to Ribbon. First, click on the task name that you want to assign resources to. Then, on the Ribbon, click on the Resource tab and select the Assign Resources button (with the icon that looks like two people). A second way to assign resources is to right-click a task and select Assign Resources. When you click on the icon, the Assign Resources dialog box will appear. Like the task list, this looks like a spreadsheet where you will identify your resources; if you have already named resources, they will appear on the spreadsheet in alphabetical order under the first column--the Resource Name column. A new column to MS Project 2010 is the R/D column, which stands for Request/Demand. Select this column when you want to add an extra emphasis to a resource’s usefulness; request is used to designate that the selected resource should be used for the task unless otherwise booked, and demand is used to designate that the selected resource must be used and cannot be substituted. The Units column is used to indicate the level of commitment of the resource. In industry, a person is usually available 100% of the time for the project, so the Units would be 100%. For shared resources the percentage would be less. For your project, it would be reasonable to assume you'll be spending about 10% of your time on the project. The labor rate is copied over automatically from your resource sheet. After you've entered the information for your resources, click OK. Do this for all the tasks in the project.

Tip: To assign a task to more than one person, hold the Ctrl key and select the resources you want for the task. By default, Microsoft Project will evenly distribute the task. To change this distribution, manually enter the percentages in the command line.

Customizing Work Time

Although standard work hours are from 9:00 AM to 5:00 PM for five days per week for a total of 40 hours, there are many instances where these standards are not actual work times such as part-time work or holidays; sometimes, workdays may be longer or shorter than the standard. To be a good project planner, you must occasionally make allowances for your resources (for your project, these are you and your teammates) to work more or fewer hours than standard depending on certain scenarios such as sickness, snow day, or emergency.

Let’s say there is a terrible snowstorm and no one can work on the project from Wednesday to Friday during the third week of the month. However, you plan to make up for it on Saturday with work for four hours and work an extra two hours on Monday.

Schedule the Snowstorm

  1. Select the Project tab on the Ribbon, then Click Change Working Time.
  2. A dialog box will pop up; Click the For Calendar dropdown arrow and select Standard (Project Schedule) if it is not already selected.
  3. Notice the spreadsheet on the bottom half of the dialog box. Under the Exceptions tab, type a descriptive title for the snowstorm in the Name column of the spreadsheet. Press Enter; then click Details. Another dialog box will appear.
  4. For the snowstorm, make sure that the working type is set to Nonworking, the recurrence pattern is Daily, and that it recurs every 1 day.
  5. Now, on the calendar, you must set the range of the snowstorm’s affect. Set the start time by either typing the desired date in the Start box or clicking the dropdown arrow to open the virtual calendar and selecting the date there. There are two ways to designate the finish date; (a) select End after: to set the number of occurrences after the start date, or (b) select End by: the exact same way you designated the start date. Notice that if you choose End after, End by automatically adjusts to your setting and vice-versa.
  6. Click the OK to finalize your schedule for the snowstorm.

Schedule the Make-up

  1. You should still be on the Change Working Time dialog box. Under the Exceptions tab of the spreadsheet, in the Name column of the cell under the snowstorm exception, type the name you want to give to the make-up day; then press Enter.
  2. Highlight the make-up day cell and click Details.
  3. In the dialog box, set the working type to Working Times, since this exception will be used toward completing a task. Notice that the default workday schedule is from 8AM to 12PM and from 1PM to 5PM with an hour lunch break from 12PM to 1PM.
  4. Now, you must set the hours for the make-up day. Since you planned to work only four hours, let’s delete the row with 8AM to 12PM so the schedule only calls for work from 1PM to 5PM. To do this, make sure the 8AM cell is highlighted; then click the 12PM cell while holding the Shift key; then press the Delete key.
  5. Make sure the recurrence pattern is set to Daily and recurs every 1 day. Select the start date using the same procedure as with the snowstorm; Set the end date to either after 1 occurrence if you use the End after option or enter the finish date if you use the End by option.
  6. Click OK to finalize your settings for the make-up day.

Schedule an Extra Day of Work

  1. Once again, the Change Working Time dialog box should still be open; type the name you desire to give to the extra day directly under the make-up-day cell in the Name column of the spreadsheet. Hit Enter to finish typing; then highlight the extra-day cell and click Details.
  2. Select Working Times as the working type, since you plan to work extra hours this day. Because you want to work an extra two hours, do not delete any times on the spreadsheet; instead, edit the standard schedule to fit the extra two hours of work. Let’s say you want to work the extra time in the evening; highlight the 5PM cell and type in 7:00 PM.
  3. Make sure to keep the settings for the recurrence pattern at Daily and every 1 day. Select the start date as with the previous exceptions, and set the end date to either after 1 occurrence if you use the End after option or enter the finish date if you use the End by option.
  4. Click OK to finalize your settings for the extra day.
  5. Notice that all the exceptions you scheduled are represented on the calendar and also notice that the start and finish dates of each exception are displayed under the Start and Finish columns respectively.

Good job! You have successfully scheduled this scenario into project. However, if a task is scheduled for a date or series of dates that have had their working hours altered, MS Project 2010 will automatically calculate that it will take one day to finish the task per the number of workday hours contained in the duration of the task. For example, you set the daily work time to just 4 hours for a week in the project, and a specific task takes 12 hours to complete. If you schedule this task to be done during this week, MS Project 2010 will calculate that the task should be completed in 3 days (since 12hrs. to complete the task ÷ 4hrs. of work per day = 3 days to finish the task).

Formatting the Gantt Chart and Customizing the Ribbon

  1. If you do not find the Gantt Chart Wizard command on the Ribbon or any other navigation tool, you must add it to the Ribbon. In MS Project and all other Office 2010 suite programs, customizing the Ribbon can now be done. To customize the Ribbon, right-click anywhere on the Ribbon and select Customize the Ribbon (This is a shortcut to easily access the Options menu of the File tab).
  2. In the dialog box that appears, there will be two list boxes. The left box is where you select the command you want to add to the Ribbon, and the right box is where you select the specific location on the Ribbon to insert the selected command. Click the dropdown arrow above the left list box, and select All Commands. Find and select Gantt Chart Wizard in the left list box; it will be easy to find since the commands are listed alphabetically.
  3. Before adding this command to the Ribbon, you must first create a custom group within a tab in which the command will be placed. In the right list box, select the tab where you want to add a custom group, and click New Group. After the group has appeared on the list, highlight both Gantt Chart Wizard and New Group (Custom), and click Add; notice that the command shows in the right list box. Click OK to finalize the customization.
  4. Locate the newly made custom group, and click on Gantt Chart Wizard. A popup window will appear introducing the wizard. Click on Next.
  5. When the next window appears, select the Standard radio button (if it is not selected already), and click Next.
  6. When the next window appears, click on the Custom Task Information radio button, and click Next.
  7. There are three fields in the window that appears:
    • For the Left: box, click on the arrow on the right and on the pull down menu, and select Name. #* For the Right: box, click on the arrow on the right and on the pull down menu, and select Resource Names.
    • For the Inside: box, click on the arrow on the right and on the pull down menu, select % Work Complete.
  8. Click Next.
    Note: There are three Milestones and a Final Presentation in EG1003. This information should be included in your Gantt Chart. Placing the Milestones here will help keep your project on track. The directions for doing this appear here later.
  9. Click Next on the three screens that follow.
  10. Then click Format It.
  11. Exit the wizard.

Note: Once you become familiar with the program, you can modify and label your schedule to better fit your project.

Inserting a New Task

Sometimes, we realize that we've forgotten something and need to add it to the project. Also, the project itself changes, so we need to add things. MS Project 2010 makes adding new tasks very simple.

  1. Select the task just below where you want to insert the new task.
  2. On the Insert area of the Ribbon’s Task tab, click the Task button or the dropdown arrow under the button to add a normal task, a recurring task, or a blank row.
  3. You can also add tasks by right-clicking on an existing task and select Insert Task to add a task right above the selected task.

Important: Be sure to update the task information for this new task so that it has the proper place in the Gantt Chart.

Adding Subtasks

For a small schedule, what we've done so far is adequate. However, most schedules are much more complex. When we're working on more complex tasks, we use a "divide and conquer" approach, where we split the overall job into a group of high level tasks, then take each of these tasks and divide them into smaller tasks, and keep doing this until we have a low level of detail. This allows us to be sure that we haven't forgotten anything, and also allow us to track the project at a high level. The lowest level tasks, which we've been doing, are called detail tasks, and they are collected into summary tasks. This section will show you how to take advantage of this approach.

  1. Enter the tasks. The first task should be the summary task, followed by the detail tasks. For the detail tasks, enter the duration and other information as we've discussed earlier.
  2. In the Task Name field, select the tasks you would like to designate as subtasks and click the Indent button on the Schedule area of the Ribbon’s Task tab. The indent button is a green arrow pointing to the right. Notice how the summary tasks now becomes a black line over the detail tasks; and if the task has no start, finish, or duration, these factors are set automatically by the detail tasks. MS Project will also override manual scheduling for the summary task, forcing it into auto scheduling. However, if what will be the summary task is manually scheduled and has start, duration, and finish times before becoming a summary task, MS Project 2010 will keep your settings for the start, finish, and duration times. If what will be the summary task is auto scheduled and has start, duration, and finish dates before becoming a summary task, MS Project 2010 will overwrite your previous start, duration, and finish values with values based on its detail tasks. Notice that the summary task is now bold print. Also, notice that a new box appeared to the left of the summary task name, and the box has a minus sign inside. For a complex project, showing the entire schedule can be overwhelming. If you click on the minus sign, the detail tasks disappear, and only the summary task is shown, making a large schedule easier to read. To make your subtasks reappear, click on the + sign that replaced the minus sign.
  3. You can change subtasks back to normal tasks by simply highlighting the subtasks you wish to change and clicking the Outdent button, the button that depicts an arrow pointing left and is located to the left of the Indent button.
    Figure 3: Tasks and subtasks.

This completes your schedule. Be sure to save your work.

Including Your Microsoft Project 2010 in Your PowerPoint Presentations

Although you need a schedule in order to control and keep track of a project, frequently you have to present your progress to others as well, typically using PowerPoint. This section will tell you how to make an effective schedule to show in your presentation.

  1. For a presentation, you want to show an overview without a lot of detail. Therefore, we'll hide the columns on the left side except for the task name. To do this, note that there's a bar between the task list and the Gantt Chart. If you hover your mouse over the bar, you'll see two arrows appear pointing left and right. This means you can move the bar. Hold down the left mouse button and drag the bar over to just behind the Task Name list. This gives your Gantt Chart more room and allows you to see more of the schedule.
  2. Select Copy Picture from the Copy dropdown list located in the Clipboard group of the Task tab of the Ribbon.
  3. A dialog box will appear. Under Render Image, click on the radio button next to For Screen.
  4. Under Copy, click on the radio button next to Selected Rows.
  5. Under Timescale, click on the radio button next to From: and in the text boxes enter the start and finish date of your project.
    Note: This step is very important. Failure to do this causes more space than you need to be copied and your picture will be too large.
  6. Go to Microsoft PowerPoint and paste (CTRL+V) the picture into your slide.

Updating Your Schedule

After we've completed the schedule, we need to show progress on the tasks we've defined so we can see if we're on schedule.

  1. Select the tasks you want to update. If you want update all tasks, click the Task Name box on the spreadsheet to highlight all tasks.
  2. On the Schedule group of the Ribbon’s Task tab, select the dropdown arrow next to Mark on Track. Select Update Tasks from the list that appears.
  3. In the popup window that appears, you'll see the task name; this won’t show if you have more than one task selected. You can update the boxes that are white. The one you'll use most often is the % Complete. Enter the percentage in the box next to it. A task that hasn't started yet would be zero, and a task that's completed would be 100%. As an alternative, you can see the task duration from the schedule in the gray box in the top right corner of the window. Below it, you can enter how much time is needed to complete the task and Project will calculate the percentage for you. When you're done, click OK.
  4. In MS Project 2010, updating the progress is very simple. On the Schedule group of the Ribbon’s Task tab, the 0%, 25%, 50%, 75%, and 100% buttons can be used after selecting the tasks you want to update.

Important: You should modify you project schedule each week.

Updating the Project

If we have many tasks, it can be tedious to update all of them when we're updating the schedule, especially since almost all of them are probably on time. This feature will allow us to update all the tasks to the date we choose, and have project calculate the percent complete for each task to match this date. Then we can change just the tasks that are ahead or behind schedule individually.

  1. On the Status group of the Ribbon’s Project tab, select Update Project.
  2. In the popup window that appears, enter the date you want to use in the box in the top right corner of the window. Then click OK.

Adding Milestones

In a project, some tasks are Milestones. As the name implies, a milestone is an important event that has already happened or will happen sometime in the future. Typical milestones are the start of the project, its completion, various reviews, completion of major systems, etc.

  1. Enter the name of the task that you want to make a milestone, or insert it if you're adding the milestone later. Enter the date for the milestone in both the Start and Finish cells. For the duration, enter zero. A diamond bullet will appear on the Gantt Chart to indicate a milestone. See Figure 4.
    Figure 4: Milestones on Gantt Chart

  2. Even though a duration of 0 automatically is defined as for a milestone and a duration other than 0 is not, you can change the definition of a milestone for any task. First, click on the Information button in the Properties group of the Ribbon’s Task tab. On the dialog box that appears, go to the Advanced tab and click on the check mark box labeled Mark task as milestone to toggle the feature on/off.

Adding a Progress Line

  1. On the Format group of the Ribbon’s Format tab, click on Gridlines. On the pull down menu that appears, click on Progress Lines.
  2. Click the Dates and Intervals tab, if it is not already selected. Click the top check box that says "Display", and click on the radio button labeled “At current date.” For your purposes, keep the other default settings the same, and then click OK to activate your progress line.
    Figure 5: Gantt Chart with Progress Line

Important: A graph on the Gantt Chart with peaks pointing to the left stands for work that is behind schedule and peaks pointing to the right stands for work that is ahead of schedule.

Project Slack

The slack, also known as float in previous versions of Project, of a project defines the amount of days that a project is early or late in meeting the final deadline. A slack of +5 days (the progress line is to the right) means that the project will be completed 5 days ahead of schedule. A slack of –5 days (the progress line is to the left) means that the project will be completed 5 days behind schedule. A slack of 0 days means that a project will finish on the final date. A positive slack is the result of tasks being completed ahead of anticipated finish dates. A negative slack is the result of tasks taking longer to complete than originally scheduled.

For the independent projects, teams are to have a slack of 0 days (on time) or better (early) in order to complete the project by the final presentation day.

In any event, accurate MS Project schedules are to be presented in all progress reports. In the event that a team has a negative slack at the time of a progress report, the MS Project Schedule with the negative slack must be presented. You should be prepared to explain how you will get your project back on schedule, and have an adjusted schedule with a slack of 0 days by the time specified by your faculty member, or the next Milestone presentation at the latest. If you modify your schedule, you should present both the new and old schedules at the next scheduled Milestone presentation.

To show slack on the Gantt Chart, click the Slack checkmark box in the Bar Styles group of the Ribbon’s Format tab.

Your work is now complete. Please clean up your workstation. Good luck with your project!