
EG1003 Help and How To’s: Revit Tutorial 

Completion of this tutorial is required for Milestone 1.  

Downloading Revit: 

Before beginning the tutorial, please download the student version of Revit 2019 on your 

computer from the Autodesk website (https://www.autodesk.com/education/free-software/

revit). This version is free, and you should use your NYU email to create an Autodesk account. 

Follow the steps on the page to download Revit. 

Helpful Mouse Tips: 

To zoom in and out, scroll with your mouse. 

To select an object, click the object or click and drag over the object (like in AutoCAD). To 

select multiple objects, click on one, hold “Ctrl”, then click the rest of the objects you would 

like to select. 

To pan around your view, click and hold your mouse’s scroller and move your mouse. 

In your 3D view, to pan and rotate at the same time, hold “Shift”, then click and hold your 

mouse’s scroller and move your mouse. 

https://www.autodesk.com/education/free-software/revit
https://www.autodesk.com/education/free-software/revit
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1. Introduction 
 

Open Revit. Under the home page, there is a column on the left side labeled “Projects”. 

Select “Architectural Template”. Each template is for a different type of design. For 

example, if you want to design a plumbing system, you would open a Mechanical Template. 

We will be working in the Architectural Template for most of the project. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

This is your home screen for a project. On the left, there is a column called “Properties” 

and below it is a column called “Project Browser”. At the top of this window is the tool 

bar. These are where all your tools and properties will be when building your structure.
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2. Setting Levels/Getting Started 
 

The most important part of setting up is defining the levels of your project (the story heights for 

the building). 
 

Go to the Project Browser column on the left and double click on East under Elevations. This 

will open a window that shows the view of the East side of your project. You can switch 

between any view by double clicking on the level or elevation name. A new window of that 

view will open (don’t worry—your first window isn’t gone, it’s just behind your new view).  
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When your window opens, double click on the current height and name of the existing levels to 

change them. Remember to check your units when you are typing in numbers! To add a new 

level, click Level (the black and white circle icon) in the toolbar under “Datum”. For a 

shortcut, you can also type “LL” and your cursor will automatically be ready to draw a new 

level. To delete a level, just click on it and press “Delete” on your keyboard. Once you have set 

your levels, you can start building.  
 
 
 
 
 
 

 

Add a new level 
 
 
 
 
 
 
 
 

 

Adjust current level 
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3. Views 
 

If you would like to view all your views at once, click the “View” tab in the toolbar, go to the 

“Windows” subtab, and click Tile Views (the icon with one rectangle on top of the other). You 

can also just type “WT” on your keyboard as a shortcut. 

 

 
 

To view your 3D model, go to the “View” tab in the toolbar, under the “Create” subtab, and 

click “3D View” (the house icon). 

 

 
 

When you select one object in your project, it is selected in ALL windows. If you have all 

windows open at once and select an object, it will be highlighted in each window. This is 

helpful in locating or viewing certain objects’ placement. 
 

Along the bottom of your window is a toolbar with various symbols. Hover over each symbol 

to figure out what each one does. The most important functions in this toolbar are the three 

symbols highlighted below.  
 
 
 
 

The first highlighted symbol is the Visual Style of your drawing. The Wireframe view is 

the most useful style to work in because you can see through all your objects. 
 

The second two highlighted symbols work hand in hand. If you would like to hide certain 

objects while you are drawing, right click on it and click “Hide in View”. You can also select 

objects and then click Temporary Hide/Isolate (the glasses symbol) to hide an object. Hiding 

an element means only hiding the object you selected. Hiding a category means hiding every 

object that is in the same category as the object you selected (ex: hiding all furniture). 
 

The Reveal Hidden Elements function (the lightbulb symbol), when clicked, shows everything 

that you have hidden in pink, along with your existing structure (like the upside down in 

Stranger Things!). These two functions are helpful when you want to build on the interior of 

your structure, but your walls are blocking your vantage point. 
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4. Building 
 

In the Project Browser column, go back to Level 1 under “Floor Plans”. You should always be 
building from the ground up, so start at Level 1. 
 

To start, select the “Wall” function under “Build” in the “Architecture” tab of the toolbar. Build 

an Architectural Wall.  

 

 
 

When you click on the function, a new tab called “Modify” should appear on the far right of the 

toolbar. This happens for any new structure you select under Build. Click what type of line or 

shape you would like to draw and draw it on your view. You should probably use the Rectangle 

tool to build your walls. 

 

 
 

If you made a mistake in the length of your walls in your initial drawing, you can always 

double click on the dimension in blue and change it manually by typing in the correct value. 

Once you are done modifying the wall, press the “Esc” key. 
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After you have created walls for your structure (just on Level 1), you can add floors, ceilings, 

doors, and windows. Just click on the structure you would like to add and place it on your 

structure. 
 

For floors and ceilings, you will need to provide a “boundary” that your floor or ceiling will 

follow. This boundary is the perimeter of your building that you created when you build your 

walls. 
 
Click “Floor”, and under the Modify tab, it will prompt you to pick a line type to draw 

your boundary with. “Boundary Line” should already be automatically selected. Simply 

click on your walls that you created, then click the green check mark.  
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The procedure for ceilings is almost the exact same. Stay in Level 1 under Floor Plans. After 

clicking “Ceiling” under the “Architecture” tab, it will prompt you to create an Automatic 

Ceiling or Sketch Ceiling. If you have a simple wall design (such as a single rectangle), you 

can use an automatic ceiling. If you have a more complex wall design shape, click Sketch 

Ceiling. The procedure to sketch your ceiling boundary is the same as the floor boundary. 

 

 
 

When creating the ceiling, a warning might show that says “None of the created elements are 

visible in Floor Plan: Level 1 View”. If you ignore this message and go to the 3D view, you 

can see that the ceiling was created but the view settings were just preventing you from seeing 

the ceiling in the Floor Plans view. Just ignore the message and move on. 

 

NOTE: Do not create your roof until you are completely done with your project and that is the 

final piece missing. This includes adding stairs, furniture, doors, and windows before creating 

the roof and ceiling. 

 

To insert a roof onto your building, stay in the Level 1 Floor Plan and click “Roof” in the 

Architecture tab and draw its footprint around the walls (same as a boundary). Revit will ask if 

you would like to move the roof you are about to create to the next level (Level 2), so click Yes. 

After drawing your roof footprint and clicking the green check mark, Revit will ask you if you 

would like to attach the highlighted walls to the roof. Click Yes.  

 

NOTE: You must create ceilings and floors before you build your roof. 
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If you would like to change the height of the roof, you can change the first number in the 

Slope dimension under the Properties tab. 

 

 
 
To install stairs, go to the level that you would like your stairs to start on. For this example, we 

will be starting on Level 1, building stairs up to Level 2. Double click on “Level 1” under 

“Floor Plans” in the Project Browser column. Select the Stair command in the Architecture tab 

of the toolbar. Once you’ve placed your stairs on Level 1, click the green check mark and 

navigate to your 3D view. Your stairs are visible but are coming right out of your floor on 

Level 2. 
 
NOTE: To do this next step, you must build a floor on your second level. 
 
Double click on the ceiling you created on your first floor (this can be easily done in the 3D 

View but may be hard to locate in your Level 1 plan view). You should now be in the 

modify mode for your ceiling. 
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Using the compass in the top right of your screen, click on “TOP” to get an overhead view of 

your stairs. In the “Modify | Edit Boundary” tab of the toolbar, click the rectangle icon and draw 

a rectangle around your stairs, so that you make a “cut” or “gap” in your floor.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click the green check and do the same procedure for the ceiling. When you’ve finished, your 

stairs should look like this. 
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NOTE: This is a 3D view, with one wall temporarily hidden so that you can see inside the 

building. 
 
You can modify your stairs’ length, height, and other dimensions by double clicking them.
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5. Modifying Objects & Changing Properties 
 
When you select an object, its specific properties show up in the Properties column on the 

left. For example, if you click on a door that is in your structure, the Properties toolbar will 

show the type of door along with other details. If you would like to change something about 

the door you are using, click “Edit Type”. Here you can change dimensions, color, material, 

and more. 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

If you would like a completely different door (this procedure also applies to windows, walls, 

columns, etc.), you must go through the process of loading a family. Click “Door” under the 

Architecture tab. Under the “Modify” tab on the toolbar is a command called “Load Family”. 

Click it and this window should appear: 
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Navigate through the folders to find which object you would like to load into your project. Once 

you have clicked it and approved, click “Open”. Revit will ask you which type/dimensions you 

want. Select the one you want and click “OK”. Now when you click the “Door” command, you 

will have multiple doors to choose from. If you click the drop down menu under Properties, you 

will see all of the options you have, including the families you downloaded. 
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If you would like to import an object such as a door, chair, tractor, or tree (anything you want!) 

that is not stored in your computer’s Revit family folders that come with the program, simply go 

to a website called BimObject on a browser. In BimObject, companies upload specifications for 

objects that they create/manufacture to this website for engineers and architects to use in their 

designs. Simply make an account on the website and download the files for Revit. You should 

use your NYU email and information to sign-up for an account on the website. After logging in, 

download the file of the item that you’ve picked, and click the Revit version from this pop up:  

 

https://www.bimobject.com/en-us
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Open the file for which you just have downloaded off BimObject. You will then be taken 

back to Revit and the following dialogue appears. Click “Upgrade the model”.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Your file will open, and you should see the object you selected on BimObject as if it were its 

own model that you can change, just like your building. Go to its 3D view. If you do not see 

your object and only see a box, that is because each object once downloaded is hidden by a box. 

Click the box and press delete. You should now see your object. Click “Load into Project” and 

you will be able to place it wherever you’d like. 

 

 
 

To find this object and other objects you have loaded into your project, go to the Architecture 

tab, click “Component”, and in the Properties panel, if you click the dropdown for the object, all 

your imported objects should be there. 

 

 
 

Helpful tip: if you are trying to rotate an object or component, click it so that it is highlighted. 
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6. Electrical Plan 
  

When creating an electrical plan in Revit, you should make copies of the Floor Plans for which 

you intend to make an electrical plan. To do this, you right-click on the desired level under Floor 

Plans in the Project Browser. Then select “Duplicate View” and “Duplicate”. 

 

                                        
 

After the new Floor Plan is created, right-click “Level 1 Copy 1” under Floor Plans in the Project 

Brower and rename it to “Electrical 1”. 

 

First, it must be noted that in order to add ceiling lights to a level, there needs to be a ceiling on 

that level. Also, the ceiling has to be a “GWB on Mtl. Stud” ceiling. You can change this 

property of the ceiling by selecting the ceiling in the 3D View and changing it in the Properties 

panel. 
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Then, go back to the “Electrical 1” floor plan and go to the Properties tab. Change the “Range: 

Base Level” from “None” to “Level 1” and change the “Underlay Orientation” to “Look up”. 

 

 
 

Next, you must insert all the desired electrical fixtures in the “Electrical 1” floor plan, such as 

lights and switches. To do this, go to the “Insert” tab and select the following: 

 

• Lights: Load Family → Lighting → MEP → Internal/External 

• Switches: Load Family → Electrical → MEP → Electric Power → Terminals  

 

To insert the switch, under the Project Browser, navigate to Families → Lighting Devices → 

Switch. Then drag and drop the switch into the electrical floor plan. It is important to note that 

the switch needs to be placed on a wall.  
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Then, on the Project Browser panel, select the light you want to drag and drop into the floor plan. 

If you want to place the light on the wall, drag it onto the wall and it will automatically snap on. 

If you want to add the light onto the ceiling, you need to click “Placement” then “Place on Face”. 

If you followed all the previous instructions correctly, you can now place the light onto the 

ceiling. 

 

 

 

Finally, you need to connect all the electrical components with a wire. To do so, go under the 

“Systems” tab and select “Wire”. 

 

 
 

Once the wire is selected, you can connect all the fixtures by selecting the purple circle with the 

“x” through it on the electrical floor plan. Each electrical fixture should have one and you should 

connect all the points with the wire.  
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Below is a complete electrical plan with all the lights connected to one switch: 
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7. Plumbing Plan  
 

In order to add a plumbing plan to your building, you need to “Link” your architectural Revit 

file to a mechanical Revit file. 

 

First, save your current file, the original Architectural Template that you’ve been working on. 

Completely close that project (make sure there are no hidden windows of the Architectural 

Template open) and go back to the homepage where you can choose to start a new project. Start 

a new “Mechanical Template” using the toolbar at the top left of the window.   

 

 
 

A new project will open, and if you look at the Project Browser panel, you’ll notice that you still 

have floor plans and ceiling plans, but they are now labeled “1 – Mech”, “2 – Mech”, etc. 

 

We will now “Link” our original Revit model into our new project. Go to the “Insert” tab on 

your toolbar and click “Link Revit”. Select your original project and open it. (Make sure it is not 

open in any other windows. It will not link if it is open. Remember to use the command “WT” to 

see all the windows you have open.)  
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To create a plumbing plan, make sure you are working under Plumbing and not HVAC.  

 

 

You can insert plumbing fixtures using the same “Load Family” function you used to insert 

furniture and lighting. All plumbing fixtures (toilets, sinks, showers, etc.) must be reinserted in 

the mechanical template. Simply inserting plumbing fixtures over the original file as linking a 

file does not allow proper access to the fixture. When inserting the fixtures, they should snap into 

place over the original fixture. Make sure you are inserting MEP plumbing fixtures, not 

Architectural. 

 

Now you must connect all the plumbing fixtures with pipes. To create a pipe, go to “Systems” 

and select “Pipe”. 
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Change the diameter of the pipe to 6” and Offset to 0”. Also make sure that the system type is set 

to “Sanitary”. This can be changed in the Properties panel under the “Mechanical” section.  

 

 
 

Create a sanitary pipe by clicking from one corner of the building to the “street.” 
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Select the plumbing fixture you inserted earlier that you would like to connect to the sanitary 

pipe. Each of the plumbing fixtures has an “out” pipe option.  

 

 
 

Select the “out” option. This will autogenerate a pipe. Change the pipe diameter to the desired 

size and select “Inherit Elevation” under “Placement Tools” in the top toolbar.  

 

 
 

Connect the out pipe from the plumbing fixture to the sanitary pipe running through the wall. A 

successful plumbing connection looks like this: 

 

 
 

Repeat this process for the remaining plumbing fixtures. 
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8. Revit to STL  
 

When using Revit 2017, the STL Exporter add-in can be used and downloaded using the 

following link: 

https://apps.autodesk.com/RVT/en/Detail/Index?id=1223946382495494802&appLang=en&os=

Win64.  

 

Models made on Revit 2019 Student Edition will not be able to convert floor plans using the 

STL converter and you will have to redraw on Revit 2017 or Fusion. 
 

In Revit 2017, to export a floorplan from a Revit file to a STL file, open your Architectural 

model. Go to the “Add-Ins” tab, in the STL Exporter Panel, and select “STL Exporter for Revit.”  

 

 
  

The following window will appear: 

 

 

https://apps.autodesk.com/RVT/en/Detail/Index?id=1223946382495494802&appLang=en&os=Win64
https://apps.autodesk.com/RVT/en/Detail/Index?id=1223946382495494802&appLang=en&os=Win64
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Change the units to millimeters, but do not change anything else in the window. Switch from the 

General tab to the Categories tab. This tab is used to select the items you would like to include in 

your STL file. Only select floor and walls. Including objects like furniture and stairs will result 

in a failed print. Click “Save”. 


